Back
Resolved
Resolved
Publishing delays — May 23, 2026
Started 23 May at 02:19pm CEST.
Publishing Scheduler
Queue Scheduler
Created
We experienced delays in our publishing queue due to a saturation in our publishing pipeline. Some scheduled posts took longer than usual to be published.
What happened: A platform incident on May 22 caused a backlog in our publishing pipeline that is still being processed.
Status: Resolved
Impact: Some posts experienced delays of up to 1 hour. No posts were lost — they will be published once the queue catches up.
Resolution: The root cause has been identified and cleared. The queue is actively recovering.
Posted 23 May at 02:19pm CEST.